DBS-C01 Sample Questions & Answers
Free Database Specialty practice questions with worked answers and explanations. See how the ExamJungle simulator prepares you — then jump into the full test.
Launch the full DBS-C01 simulator →Free DBS-C01 Sample Questions with Answers
Real questions from the AWS Certified Database Specialty practice test — answers and explanations included. Showing 6 of 12 free samples.
- Question 1
A large financial services company requires that all data be encrypted in transit. A Developer is attempting to connect to an Amazon RDS DB instance using the company VPC for the first time with credentials provided by a Database Specialist. Other members of the Development team can connect, but this user is consistently receiving an error indicating a communications link failure. The Developer asked the Database Specialist to reset the password a number of times, but the error persists.
Which step should be taken to troubleshoot this issue?Show answer & explanation
Correct answer: B
B
- Question 2
A large company is using an Amazon RDS for Oracle Multi-AZ DB instance with a Java application. As a part of its disaster recovery annual testing, the company would like to simulate an Availability Zone failure and record how the application reacts during the DB instance failover activity. The company does not want to make any code changes for this activity.
What should the company do to achieve this in the shortest amount of time?
Show answer & explanation
Correct answer: C
Reference: https://wellarchitectedlabs.com/Reliability/300 Testing for Resiliency of EC2 RDS and S3/Lab Guide.html
- Question 3
A database specialist is building a system that uses a static vendor dataset of postal codes and related territory information that is less than 1 GB in size. The dataset is loaded into the application’s cache at start up. The company needs to store this data in a way that provides the lowest cost with a low application startup time.
Which approach will meet these requirements?
Show answer & explanation
Correct answer: A
A
- Question 4Select 3
A media company is using Amazon RDS for PostgreSQL to store user data. The RDS DB instance currently has a publicly accessible setting enabled and is hosted in a public subnet. Following a recent AWS Well-Architected Framework review, a Database Specialist was given new security requirements.
•Only certain on-premises corporate network IPs should connect to the DB instance.
•Connectivity is allowed from the corporate network only.Which combination of steps does the Database Specialist need to take to meet these new requirements? (Choose three.)
Show answer & explanation
Correct answers: D, E, F
D, E, F
D, E, F
D, E, F
- Question 5
A company just migrated to Amazon Aurora PostgreSQL from an on-premises Oracle database. After the migration, the company discovered there is a period of time every day around 3:00 PM where the response time of the application is noticeably slower. The company has narrowed down the cause of this issue to the database and not the application.
Which set of steps should the Database Specialist take to most efficiently find the problematic PostgreSQL query?Show answer & explanation
Correct answer: D
D
- Question 6
A Database Specialist must create a read replica to isolate read-only queries for an Amazon RDS for MySQL DB instance. Immediately after creating the read replica, users that query it report slow response times.
What could be causing these slow response times?Show answer & explanation
Correct answer: B
B
Ready for the real thing?
The full DBS-C01 simulator has every exam-style question, timed mode, and instant scoring.